Home Seek Help
This forum is intended for MultCloud Support Discussion. Please post/inquire on existing discussions if they exist.

Can't Log In - FireFox, Edge, Edge Dev

On any of the three above browsers I can't log in.

What's happening here? If I look at the developer tools it is even sending the API sign_in_ command successfully, but it still does not log in.

I have disabled all extensions, and tracking protection and tried in private browsing. What could be the issue here?

The Log in screen simply does not progress after tapping 'Log in' it stays the same. I have also tried multcloud.com/login and it is the same.


  • I'm facing the same issue,I've tried Firefox,Opera and chrome,I also disabled all the extensions but no luck, It used to give a captcha to solve then it lets you in but i can't see it, I sent a ticket regarding the issue to the support email an hour ago I hope this gets resolved soon. Thank you.
  • all day with the same problem.
    And when I get the login it doesn't work to be able to add new google clouds (shared drive/drive)
  • @Eliotcole @Thomas01@Ctirado, Sorry for the inconvenience. We have fixed the problem. Please try again.
  • @Admin I just checked and i confirm its working,Thank you so much

  • Hallo

    das gleiche Problem tritt jetzt schon wieder auf ???? 

  • Same problem is back again. The "Login" button is pressed and the request is sent but nothing happens.
  • edited April 2
    Same for me - can't log in.
    AND, the regular tasks that should normally run on a schedule have not run since 28th March.
  • edited April 3
    oh shoot ! We are facing the exact same problem again
  • Guys @multclown @webmaster @rddomain its working now,try to log in now.

  • edited April 5
    I have managed to log in at last. Used a different browser with empty cache.
  • I cant seem to get past homepage/login page.

    Multcloud has since not been working on my chrome browser (possible for all chromium browsers).

    This issue has been there since April.

    I have not been able to login since then.

    Please help!
  • @Feminagasaki, Please clear the cache and cookie of your browser, and then try to access and login MultCloud again: https://www.multcloud.com/
    If you still get error, please take a screenshot to us.
  • edited May 28
    I can't login again,I also tried the mobile app it says ;(Server Error Please try again later) I used different browser with empty cache but still the same issue,Anyone else or just me?!
    Update : It's working fine again,Thank you
  • Hi,It seems multcloud is down,I checked this reporting site ; https://www.saashub.com/multcloud-status And it seems it's not just for me,Hopefully the issue will get fixed soon, Thank you
  • Hello,
    Thank you for contacting MultCloud,
    Please Try using Chrome browser or another computer to log into MultCloud using an incognito window. 
    When pressing Login, wait for the captcha verification to show to complete the captcha. 
    If that fails, try refreshing the page and logging in again. You may need to reset your password to log in.

    If you have any issues, multcloud support is able to assist.
Sign In or Register to comment.