Home Seek Help
This forum is intended for MultCloud Support Discussion. Please post/inquire on existing discussions if they exist.

Extremely slow transfer rate

I'm doing one transfer between 2 Gdrive and it's getting at ... 1Kb/s even if I have already suscribed to the 19$ option for 10 files at the same time.
What's wrong please?


  • Here is the screenshot
  • @Ydp, did you run the plan before you subscribe to the service? Please cancel it and then run the task again.
  • Yes I ran the plan before to start
  • I've stopped and re-started. Check the result :-(
    It's "better" but still very slow !

  • and it's getting slower and slower. Please do something. It looks like it' is working with 1 computer in your garage

  • @Ydp, As for the speed, a lot of factors should be taken into account, like the size of your files, the type of your files, the number of the files, the type of your clouds, the API restrictions of the cloud providers to third-party services like MultCloud, and so on. For example, if the big size folder you transferred has too many and too small files, then it would take much time to count these files. Actually, you can see the changes of the files number to measure the speed.
  • Thanks but the provider is Google on both sides and even if there are a lot of files to transfer, less than 2MB doesnt seems realistic and profesional to me.
  • Hi @Ydp ,

    Thank you for contacting MultCloud. I just finished reading your post and appreciate your taking the time to share your concerns with us.

    I am sorry your files was not ready to go. I would also like to take this opportunity to apologize for the slow speeds occurred from transferring your files. I totally understand it may have defeated the purpose of cloud transferring. I will be glad to help.

    I completely understand how valuable your time is. So, I want to make sure we address this in the best and most attentive possible way. Having said that, I might share your experience with the development team of Multcloud for their review.

    There are instances where MultCloud can't transfer files fast to the speed of your expectations. If we try to transfer with more speed, Google may block your account, or this service as a whole. So this is why the speeds here are reasonable.
    Fast enough to copy the files from one place to another, slow enough to keep the service going.

    I would suggesting restarting the task, if you just upgraded to get 10 threads to transfer files.
    If this issue still persists, you can try deleting the connection from MultCloud and re-adding the connection at both the source and the destination drives.

    If you have any further questions, please don't hesitate to contact us.
  • hi I have the same problem from dropbox to google drive....first I tried the free acount and it worked superb. I have now a paid account and now it doesnt do anything..even not over night.. what is wrong?
  • @Zeitgeist, Could you give us a detailed description of your problem situations or take some screenshots so that we check?
  • edited February 2023
    same problem here.
    from ftp to gdrive.

    Result: Failure
    Files Processed: 249/458
    Data Processed:2.01MB/4.94MB
    Start Time: 2023-02-06 14:56:47
    End Time: 2023-02-06 16:04:29
    Avg.Rate: 519Bytes/s

  • 1h for 2MB

    very nice.

    I have a MultCloud Lifetime Unlimited user account.
  • Hi support,
    Few days ago (10/2/2023) I have started a task to copy data from Google Drive to Dropbox. The size of files & folder when added is around 100Gb (more or less). However since it takes more than few days, I have cancel and restart the same task but nothing happen. Its like the task progress freezing around 24-26 percent. Afraid of the problem come from cloud limitation, I make decision to switch from Google Drive to Dropbox towards OneDrive to Google Drive. Yet, nothing happen. Please advise. I have subscribe to Unlimited/ Lifetime plan few years ago.
  • @Tbyte, Could you rerun your task again? If it still get the same situation, please contact the support team via email and help you check the problem further.
  • I have rerun it few times. Where should I send support an email? Today, the task suddenly freeze and not moving. 
  • @Tbyte, please check the contact email: https://www.multcloud.com/support
  • see for yourself task from 25-02-2023 still running until today (3-3-2023). Already contact support and they give me solution. See attachment.
  • @Tbyte, Sorry for the inconvenience. Have you completed the transfer now?

  • Hi and good day support,

    Few days ago I had perform new task which around 1.84 Tb in size but until now it is incomplete (might probably stuck halfway). Later on I have decided to deleted it and restart the task again later. 

    After cancelled the old task, I refreshed the browser and I am suprise to see old task  is running again. 

    I cancelled it again and again and after that I refreshed the browser page and guess what? Old task re-appear again and resuming. 

    Please help me solved this problem. See my attachment for supporting document.
    Thanks in advanced.
  • @Tbyte, This is a bug. We will fix it asap. Please check if the task has been canceled now.
  • Ok I have checked everything and confirmed that everything has back to normal like it is supposed to. I will update you if faced anything abnormal again regarding your services. Thanks in advanced.
Sign In or Register to comment.