Home Seek Help
This forum is intended for MultCloud Support Discussion.

Service Down - Unable to Login

I am currently unable to login, can you please investigate?


  • Me too, for 2 days now. Quite disappointing.
  • It was working just fine for me yesterday night. I was having users upload to a linked folder. But today, none of my clients can upload and get that gateway timeout error.
  • Hi I am having the same problem for the last two days. Please Help. 
  • I think the link between MultCloud and Google is broken. In my tests, I was able to create and log in successfully with an Apple account.
  • Trying to sign in with Apple doesn't work either for me. Nothing works, appears to be offline.
  • I Tried resetting the password, Google login, Facebook login and apple login with no success. 
  • @Admin are you able to give an update on the issue yet? I will need to switch to another service soon as I rely heavily on MultCloud to be up .99999% of the time.
  • Looks to be resolved now.

    BTW @LonelyScythe I hope you mean 99.99% otherwise your expectations are quite low ;) 
  • lol yes 99.999% and thank you @rhinoroo for the correction
  • I can login but nothing works. Just says "waiting"
  • Sorry for the inconvenience. We have fixed the issue. Please try to login again.
    @Chuck27p, please cancel the waiting, and then run the task again.
  • Service is working again, thanks.
  • cant login this morning to desktop site keeps looping back to homepage. im using sso on google, my iphone app is ok 
  • the issue is not fixed
  • My symptoms are just the same April 27th - and didn't auto backup yesterday - so broken under the hood too?
  • Hi, I can't login and it's my first month I tried Multcloud almost ending...and guessing if's worth to continue if I can't access :neutral:
  • I am also experiencing this issue. I have reached out to the support team via email but have not received any confirmation that my message was received. Has anyone else contacted support or MultCloud leadership about this outage?
  • Sorry for the inconvenience. We have fixed the issue (google login failture). Please try to log in it again.
  • Thank you @Admin i can confirm that Google authentication service with MC is functional now. What was the issue?
Sign In or Register to comment.